Hope for others… M-Audio Fast Track Pro

Posted on 26 July 2011

iMac Desktop Layout

A/V Addiction

I mentioned in a few earlier blog posts that I recently began dabbling in the audio / video world. Amongst my dabbling, a few of my first purchases happen to be an M-Audio Fast Track Pro and a set of KRK Rokit studio monitor speakers. Initially connecting and setting up the new device was simple, but brought with it a challenge of identifying a confusing (for me) static / noise that was heard over everything played through the device.

Getting to the point; The purpose behind this post is to hopefully help anyone who might run into the same problem I did when installing the M-Audio Fast Track Pro on Mac OS X 10.6.8, specifically an i7 3.4Ghz iMac.

(my setup on the right)

Issue

Upon connecting the USB interface for the M-Audio device and installing the appropriate device drivers for OS X (these change the default behaviour of the audio sub-system), each of the Rokit studio monitors were emitting static and noise during any and all audio playback.

Re-installing had no positive effect and all static was limited to audio playback through the M-Audio device.

Remedy

Opening the M-Audio Preference pane (OS X System Preferences) and deselecting all but the first option, cured the static / noise problem completely. In my case it turned out to be a simple driver / compatibility problem that was remedied with a little configuration change. A screenshot is included below that shows the only option enabled being the “Outputs 1 & 2 (balanced and unbalanced)”.

M-Audio Fast Track Pro System Preferences

I hope this finds usefullness for someone. I had absolutely no luck finding a solution anywhere else online including the M-Audio forums, which unfortunately included instructions to return the device. Fortunately for me, it was a simple fix. Only took a few minutes of experimentation to find it.

Enjoy.

~moses


5 responses to Hope for others… M-Audio Fast Track Pro

  • alvaro says:

    I set the 16bit option besides the 24bit, and works for me, and you can use all the outputs and inputs as well, i hope m audio fix this problem soon.

  • Kenneth Bitz says:

    Thanks for sharing this experience and new knowledge. Good to know.

  • Dallas says:

    I cannot access the setting for my device in Mac 10.6.8 system preferences. Any advice?

  • JeanMarc says:

    Thanks man! I was almost trowing my fast audio pro to the bloody highway 🙂

  • C418 says:

    Thank you, I was about to give this device directly back to where I ordered it. Ridiculous that the standard options give out static.

  • Recent Posts

    Tag Cloud

    Aanval App Apple Badger Mt. Beef book Calf Cattle Cocoa Cows development Eclipse F-250 F-450 Flex Builder Ford Gaming Horse House IDS iPad iPhone John Deere King Ranch mac Moses Ranch Objective-C off-grid Offgrid Office Outback Press Property Ranch Reining Riding Security Snort Snow tactical flex Tractor Trailer VFX Weather Xcode

    Meta

    Loyal Moses is proudly powered by WordPress and the SubtleFlux theme.

    Copyright © Loyal Moses